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Fallos de firewall o conectividad de tráfico

Problema

Los datoslog de su aplicación Java muestran fallas al conectarse a New Relic. Desea verificar si los mensajes INFO se deben a la conectividad del tráfico o a las reglas del firewall, o si se deben a problemas más graves.

Solución

Los fallos ocasionales al conectarse al recolector New Relic no deberían ser motivo de preocupación. Estas fallas no deberían afectar el rendimiento métrico disponible en la interfaz de usuario New Relic de su aplicación.

El agente de Java de New Relic intenta conectarse aproximadamente una vez por minuto. Para solucionar el problema:

  1. Busque en su archivo de registro INFO mensajes sobre fallas de conexión.
  2. Compruebe con qué frecuencia aparecen los mensajes.

Por ejemplo, busque mensajes como:

Jul 31, 2017 21:37:14 +0000 NewRelic 10
INFO: Failed to connect to collector.newrelic.com.:443 for My Application:java.net.
ConnectException: Connection refused:connect

o

Jul 31, 2017 21:37:14 +0000 NewRelic 40
INFO: The data collector is temporarily unavailable.
This can happen periodically. In the event that availability of our servers
is not restored after a period of time,
then please report this to New Relic.
java.net.SocketException: Connection reset

Dependiendo de la frecuencia con la que aparezca el mensaje, haga lo siguiente para solucionar el problema:

Frequency of INFO message

Comments

Unos minutos

El agente de Java de New Relic puede almacenar en caché una cantidad significativa de datos métricos cuando no puede conectarse. Incluso si la interrupción dura unos minutos, en general, esto no resultará en ninguna pérdida de información en laUI . Puede ignorar estos mensajes con seguridad.

De forma intermitente durante unos días.

Los problemas de conexión intermitentes pueden provocar ocasionalmente muchos de estos mensajes en poco tiempo. Si esto ocurre solo una vez cada pocos días y todos los datos de su aplicación aparecen en la UI de New Relic, puede ignorar estos mensajes con seguridad.

Cada minuto durante varios minutos.

Si se producen fallas cada minuto durante más de unos pocos minutos, entonces el agente de Java no podrá recibir datos de su aplicación y no se podrán informar datos. En esta situación:

  1. Verifique si New Relic está experimentando problemas de disponibilidad: verifique el estado de New Relic en status.newrelic.com.
  2. Si New Relic no informa ningún problema, recopile información de resolución de problemas para su aplicación.

Causa

A pesar del texto log , este error generalmente se debe a una falla de conectividad o tráfico de firewall en lugar de que el recolector New Relic no esté disponible. Para obtener más información, consulte las listas de rangos de IP utilizados por todos los servicios de New Relic.

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