Problema
Después de generar tráfico para su aplicación y esperar cinco minutos, ninguno de los datos de su agente .NET aparece en la UI de New Relic.
Solución
La ausencia de datos puede deberse a varios motivos.
Common causes
para datos faltantes: consulte las soluciones básicas de resolución de problemas.
Other situations:
Si las soluciones básicas no resuelven el problema, la falta de datos puede ser más intrínseca a su sistema. Para obtener más información, consulte las soluciones avanzadas de resolución de problemas.
Microsoft Azure users:
Consulte las soluciones de resolución de problemas de Azure.
No browser data appears:
Consulte los consejos de resolución de problemas al utilizar el agente del navegador.
Soluciones básicas
Para solucionar los motivos más comunes por los que faltan datos, pruebe estas soluciones según corresponda.
Basic solutions | Comments |
---|---|
Verifique la compatibilidad de la aplicación y framework con el agente | Compatibilidad y requisitos de .NET framework o |
Obtenga más información sobre problemas de instalación comunes | Ver resolución de problemas para .NET Core y Linux o resolución de problemas para Windows |
Configurar para procesos .NET de corta duración | Si tiene un proceso de corta duración (menos de 60 segundos), es posible que no proporcione datos. Para obtener más información, consulte Supervisar procesos de corta duración. |
.NET Core: Consulta los requisitos de Kestrel. | Asegúrese de estar utilizando una aplicación/servidor web Kestrel compatible con New Relic. De lo contrario, es posible que deba asegurarse de que su agente .NET tenga habilitada la compatibilidad con .NET Framework . |
.NET Core: Verifique las variables de entorno. | Asegúrese de haber configurado todas las variables de entorno requeridas y luego reinicie el agente. |
.NET Framework: Reinicie IIS. | Si su aplicación no recibe tráfico, no se informarán datos a New Relic. Para reiniciar IIS:
|
Ejecute diagnósticos New Relic . | Para intentar identificar automáticamente el problema, utilice New Relic Diagnostics. |
Verifique si hay conflictos con el generador de perfiles. | Si está utilizando System Center Operations Manager (SCOM) de Microsoft, siga los procedimientos de resolución de problemas para resolver conflictos .NET y SCOM. |
Revisar archivo de registro. | Si existen archivos de registro , ábralos y revíselos en busca de errores. |
Soluciones avanzadas
Para solucionar problemas más complejos cuando no aparecen datos, pruebe estas soluciones según corresponda:
Advanced solutions | Comments |
---|---|
.NET Framework: Verifique los permisos del Registro. | Compruebe si hay un error de permisos de clave de registro. |
.NET Framework: Ejecute el Visor de eventos de Windows. | Si es aplicable:
|
Obtener registro de depuración. | Si su registro no mostró errores, aumente el nivel de registro temporalmente para recopilar el registro |
Verifique la configuración del proxy. | Asegúrese de que la configuración de su proxy sea correcta y de que su configuración incluya un atributo de host. |
.NET 8: Asegúrese de que los diagnósticos en tiempo de ejecución estén habilitados | A partir de .NET 8, configurar la variable de entorno |
Obtenga ayuda adicional. | Si los datos aún no aparecen, obtenga soporte en support.newrelic.com. |