Problema
Después de generar tráfico para su aplicación .NET y esperar cinco minutos, los datos aún no aparecen en la UI de New Relic.
Solución
Importante
Consulte con el administrador de su sistema antes de cambiar los permisos.
Asegúrese de que la identidad del grupo de aplicaciones tenga
read
acceso a la clave de registro New Relic ubicada en:HKLM\SOFTWARE\New Relic\.NET Agent\Otorgue a todos los usuarios del sistema acceso a esta clave de registro o permita que solo la identidad del grupo de aplicaciones acceda a la clave.
Desde la línea de comando, realice un IISRESET.
Si la actualización de permisos no resuelve el problema, siga los procedimientos de resolución de problemas del agente .NET para datos faltantes.
Sugerencia
Para evitar que este problema ocurra en instalaciones futuras, desinstale WSM 3.3.5.0. Si no desea realizar cambios en su registro, desinstale WSM y .NET y luego reinstale las últimas versiones.
Causa
Una razón común por la que los datos no aparecen es porque el agente New Relic .NET no puede acceder a sus claves de registro. Es posible que vea errores de permisos de registro en el registro de su generador de perfiles en:
%ALLUSERSPROFILE%\New Relic\.NET Agent\Logs\
Por ejemplo, puede ver:
[Info] ... Logger initialized[Error] ... Unable to find New Relic Home directory in registry or environment.[Error] ... An exception was thrown while initializing the profiler.